Ayuda con mi Lime-Node para conectar mi nodo como cliente wifi

Tengo la siguiente situación, tenemos una conexion de internet en una Casa la cual se conecta a un Nodo con una antena de 5ghz TP-Link CPE510. La conexión con el nodo no es del todo buena, la Intensidad de la Señal desde la antena es de -72 /-73, la intensidad de ruido -91dbm, el SNR esta en 18 db y Transmitir CCQ oscila entre 94 y 100, La antena esta en modo cliente y por ahora no logramos que inyecte internet de la casa en la red. Muestro el lime-node del nodo:

config lime 'system'
        option hostname 'Nodo-Suri'
        option firstbootwizard_configured 'true'

config lime 'network'

config net 'wirelessclientWAN'
        option linux_name 'wlan2-sta'
        list protocols 'wan'

config lime 'wifi'
        list modes 'ap'
        list modes 'ieee80211s'
        option channel 'auto'
        option client_ssid 'InternetDesdeRoja'
        option client_key 'laClaveestaenelnombre'
        option client_encryption 'psk2'
        option distance '4000'

y desde el nodo con el comando:

iwinfo wlan2-ap asoc
xx:xx:xx:xx:24:DA  -77 dBm / -86 dBm (SNR 9)  30 ms ago
	RX: 15.0 MBit/s, MCS 0, 40MHz                   3828 Pkts.
	TX: 6.5 MBit/s, MCS 0, 20MHz                    3401 Pkts.
	expected throughput: unknown

Aclaro que la antena esta a 3200 metros del Nodo y que la visibilidad no es enteramente optima, pero se ven. Que estamos haciendo mal? no logramos hacer estable la conexion y no logramos pasar el internet a traves de la antena hacia el resto de la red.
Con la ayuda de Pablo de Montenet compilamos un bin para meterle mesh a la antena pero no estamos seguros de como ira a quedar la misma luego (nos asusta un poco) ya que es un lio reconfigurar por la distancia. Bueno, son muchas cosas, gracias por cualquier aporte! Saludos!!

Hola Juan! No me queda claro los equipos que hay, hay un LibreRouter y un CPE510? O un CPE510 que se conecta a un equipo de un proveedor?

Por lo que interpreto hay un CPE510 en modo AP y un LibreRouter que la idea es configurarlo en modo cliente.

Para configurar el LibreRouter en modo cliente, proba con esta mini guía que escribi ayer Cómo conectar el LibreRouter como cliente WiFi

Un problema posible es que no esté obteniendo IP por DHCP del CPE510. Una ayuda puede ser mirar con ip a show wlan2-sta. Si es esto puede ser que sea necesario reiniciar si es que corriste lime-config. Podes tambien probar poniendo ip fija temporalmente, por ejemplo:

ip a add 192.168.0.99/24 dev wlan2-sta
ip r add default via 192.168.0.1 dev wlan2-sta

a ver si va por ahi.

En la Casa baja un internet de un proveedor por aire que entra a un router nisuta de 3 antenas, el cual reparte en la red de la casa, la antena cpe510 esta conetada a otro router dlink dir-300 que difunde wifi sin dhcp y ve a un librerouter que esta a 3200 metros y que espera que le pase el internet desde la casa.
La guia que publicaste es para 2,4 ghz, sirve lo mismo para 5ghz?
La antena tplink cpe510 tambien tiene apagado el dhcp.

Conecte la antena a otro router porque no queria hacer lio con el dhcp del router nisuta en la red comunitaria, creo que se nota, pero estoy medio perdido con esto, je, mil disculpas!!

Todo bien!

Ahhhh … solo hay 4 equipos involucrados :smiley: No se bien como estarán conectados el CPE510, el dlink dir-300 y el nisuta.
Si te conectas con un celular o computadora al CPE510 anda todo bien ? Si eso anda bien entonces es solo configurar bien el LibreRouter, no?

Sí, se deberia usar la radio1 o radio2 (y wlan1 o wlan2) para GHz. Por favor podrias editar el articulo del wiki para que quede mas claro si no se entiende?

(me tome el atrevimiento de editar el título del post para que quede mas claro, si no es lo correcto por favor podrías editarlo?)


Ahora el cpe estaría como cliente y la idea es ponerlo como ap

Ah buenisimo! Graias por los esquemas y aclaraciones.
Yo dividiría el problema en 2 pasos si es posible:

  1. Hacer que el CPE510 y el resto de los equipos anden de forma tal de que usando un celular o notebook se pueda conectar al CPE510 y ande bien internet. Para eso van a precisar un equipo con 5GHz.
  2. Hacer que el LibreRouter ande como cliente.

Tengo un iphone 6 que se puede conectar a redes de 5ghz, servirá?

Claro!, Dejando el CPE510 de tal forma de que cuando te conectes con el celu le ande internet (sea lo que sea que haya que hacer en el CPE510!) luego con el LibreRouter va a ser facil.

entonces, saco el dir-300 y conecto la antena al nisuta que reparte internet? e intento conectarme con la antena desde el celu?

Si podes conectar el CPE-510 cableado directo al nisuta y que el CPE-510 y poner el CPE-510 en AP debería andar bien (nunca un CPE-510 no me queda claro si tiene WAN y LAN y eso)

solo tiene una boca de red y ni idea si es wan o lan!!

Hola, espero me sigas teniendo paciencia. Ahi hice exactamente esto de poner la antena en el router que da dhcp con internet y despues de poner la ip en dinamica, le dio una ip en el rango del router que esta en 192.168.4.xxx y tomo internet, y desde el celular me conecte y pude usar internet desde el
Ahora el tema que en el lime-node del nodo esta en" list modes ‘ap’ " porque ese nodo esta en el medio de los 3 que tenemos y recibe el internet de otro nodo y manda internet al tercer nodo. la pregunta es si le puedo meter los dos modos al mismo tiempo en el lime-node? porque lo que creo que le falta es estar en modo cliente para tomar la info de la antena.

Genial!

Entonces la idea es que con una de las dos radios de 5GHz el librerouter haga de cliente y tambien mesh. O sea, que tenga dos interfaces, una en cliente tambien conocido como station, y otra en mesh tambien conocido como ieee80211s.

Lo que se necesita es entonces es saber cual de las dos radios va a apuntar al CPE510 (y al otro LibreRouter). Es importante saber esto porque necesitamos que el canal de frecuencia coincida con el del CPE510 porque en una radio se pueden tener dos interfaces distintas (station y mesh) pero ambas tienen que estar en la misma frecuencia y ademas coincidir con la frecuencia del otro LibreRouter.
Por defecto la radio1 usa el canal 48 y la radio2 el canal 157. Suponiendo que la antena que apunta hacia el CPE510 es la que esta conectada a la radio2 es necesario que configures el CPE510 para que esté como AP en el canal 157.
Una ves hecho eso el archivo lime-node del LibreRouter deberia quedar así:

config lime 'system'
        option hostname 'Nodo-Suri'
        option firstbootwizard_configured 'true'

config lime 'network'

config lime 'wifi'
    option distance '4000'

config wifi radio2
	list modes 'client'
	list modes 'ieee80211s'
	option channel '157'
	option client_ssid 'InternetDesdeRoja'
	option client_key 'laClaveestaenelnombre'
	option client_encryption 'psk2'
	option distance '4000'

config net wirelessclientWAN
	option linux_name 'wlan2-sta'
	list protocols 'wan'

config net lm_hwd_openwrt_wan
	option autogenerated 'false'

Con el list modes ap y ieee80211s le decimos que tenga configurado en modo ap y mesh en la radio2.
Despues hace falta correr lime-config y reiniciar.

Espero se entienda!

pero el modo ap no lo pusiste en el lime-node, actualmente tenemos una linea:
list modes ap

La configuración final se hace a partir de la combinación del archivo lime-node, el lime-community y el lime-defaults. Acá estoy escribiendo como funciona la configuracion de LibreMesh https://hackmd.io/CWm5MbwrToevK1-mLh4Y-Q (es una version muy preeliminar pero puede ayudarte a entenderlo, aunque no habla sobre las configuraciones de radio especifcas).

Estoy asumiendo que en el lime-community vos tenes activado el modo ap por lo cual todas las radios salvo la radio que estamos forzando explicitamente (la radio2) quedarian configuradas con el modo ap y mesh y en cambio la radio2 quedaria en modo cliente y mesh.

Agrego configuración para que la radio de 2.4 GHz sea cliente y al mismo tiempo AP y con clave. En el lime-node agregar:

config wifi 'radio0'
	list modes 'client'
	list modes 'apname'
	option channel 'auto'
	option client_ssid 'COMPLETAR'
	option client_key 'COMPLETAR'
	option client_encryption 'psk2'
	option apname_ssid 'el-valle-reinicia/%H'
	option apname_key 'COMPLETAR'
	option apname_encryption 'psk2'

config net wirelessclientWAN
	option linux_name 'wlan0-sta'
	list protocols 'wan'

config net lm_hwd_openwrt_wan
	option autogenerated 'false'

Luego correr lime-config y lime-apply. Puede requerir reiniciar

1 Like