Fixing broken routing

I’m getting my LR set up for the first time. I updated to libremesh with the 1.4 image, and set up the router using limeapp. It was working fine serving the upstream internet connections on the WAN port to devices connected via wi-fi and the LAN port. Then I wanted to see what devices were connected to the LR, and couldn’t find a simple way of doing this via the web interface, so I installed luci. This seems to have broken the routing, as devices connecting to the LR now do not connect upstream. I removed luci, but the problem persists.

How do i reset the configuration to the default, and how do i easily see what devices are connected to the LR without having to ssh into the device? I guess i could reload the firmware image again, but that seems a bit drastic.
Even after rebooting the device route -n now says:

Destination Gateway Genmask Flags Metric Ref Use Iface UG 0 0 0 eth0.1 UG 10 0 0 eth0.1 U 0 0 0 br-lan U 0 0 0 anygw U 0 0 0 eth0.1

Hi Mike! Nice to see you over here :slight_smile:

LibreRouterOs and luci do not play well together. You can restore the default configuration by running firstboot command in the LibreRouter, or by following this guide to do it by pressing the reset button: How to reset the LibreRouter configuration

There is no current way to checkout connected devices using the LimeApp. We may add it soon, it would be awesome!

By now, you can check it out by running these commands:
iw wlan0-apname station dump which will print statistics for each device connected to the AP with the ssid following this template: <community_name>/<node_name>

iw wlan0-ap station dump which will print statistics for each device connected to the AP with the ssid equal to the <community_name>

cat /tmp/dhcp.leases which will print all devices that received an ip address given by your LR, their mac addresses IPs and hostnames.

If you want to run this commands from the LimeApp, in LROS 1.4 you can open a terminal session from “Menu -> SoporteRemoto” and then create a session and show the web console.

I hope this will help you!

Thanks Germán! much appreciated. I got it working with the firstboot command.
Just FYI, in case it is relevant, upon running firstboot i got:
“/dev/mtdblock6 is mounted as /overlay, only erasing files”

Anyway, the router is now running fine after i reconfigured it, and it is providing Internet access to the devices connected to it. I wasn’t able to get your suggested iw dump commands working, sorry, i’m missing something about the syntax, but i got the list of connected devices through the dhcp leases file.

From this i was able to verify that my RPI4 is connected to the LAN port, and i was able to ssh into it from my laptop when it is connected to the LR via wifi. My problem is that the devices connected directly to the LR (i.e are using LR assigned IP numbers) are not reachable from devices connected to the router that provides the LR with its upstream Internet connection via the WAN port - they are assigned IP range from a different network. So the RPI4 can no longer act as a server except for the devices directly connected to LR, and I’m wondering about the best way to address this. I am guessing that I should assign the LR a static IP on the upstream router’s network, disable the LR’s DHCP, and bridge the WAN with the LAN port? I’m a bit worried about disabling DHCP if i add additional LRs to the network, but if this is the best approach, any tips on how to accomplish this?

Thanks much…

Hi Mike!
I think, but I am not sure, that you need to configure static routing in your ISP router so that the ip range of the mesh network is routed to the LR that is connected to the ISP router. So you have two networks and both know how to reach each other, the mesh network knows that all have to be routed to the upstream LR (the default config), and the other devices connected to the ISP router know that they have to go through a specific port in the LAN switch. This config may not be possible through the router interfaces if it doesnt have openwrt.

Another way, but I am less sure that it will work, is to convert the WAN port of the LR into a LAN port and use the same ip range for everything. I never tested this setup. But to convert the LR WAN port into a LAN port you can do it for example uninstalling the lime-hwd-openwrt-wan package (opkg remove lime-hwd-openwrt-wan), then lime-config and reboot.