How do we stop the internet from being shared from one router to the other AUTOMATICALLY?

i have an uplink in my librerouter (say named ABCD). so added password to it.

recently we turned on another librerouter, haven’t completed the firstbootwizard on it, but internet is already available on this router’s open access points.

during the firstbootwizard on the new router, even upon selecting to create a new network, the internet still gets shared.

also noticed that when we choose “scan for existing networks” in the firstbootwizard, the new router is not showing my old one (ABCD). yet in the metrics page, the uplink is shown through my old router (ABCD).
(we did not connect the 5GHz antennas to both the routers)

we did figure out that meshing happens through the ieee80211 5GHz radio called “LiMe”
so when we renamed this id “LiMe” to “LeMon” on old router (ABCD), the internet stops getting shared.

is this a correct way to handle this? are there better ways to do this?
also when we select “create a new network” in the first boot wizard, shouldn’t the new librerouter not use on old librerouter’s mesh link?
in other words, is renaming the ieee80211 mesh id, the only way to isolate one librerouter network from another librerouter?

finally coming back to the main question, how to stop one librerouter connecting to another librerouter for uplink automatically?

Hi @alemaree ! These are very good questions and great that you investigated and tried some solutions!

At this moment and by default all libremesh networks interconnect to each other and share gateways to other networks (including “internet”). Even if using firstbootwizard the resulting mesh id is the same. This is to simplify interconnection between community networks.

To separate the networks completely, as you correctly found, the ieee80211s_mesh_id option has to be different (so, change the value, and then run lime-config and reboot).

If you want two liberouters to be in the same network but not share internet then you must turn off babel (the dinamic routing algorithm to share gateways). There are multiple ways to do that, for example turn off the babeld server in the librerouter running /etc/init.d/babeld disable and then reboot.

Another way is to remove babel protocol from the list of enabled protocols in libremesh (untested):

config lime network
	list protocols ieee80211s
	list protocols lan
	list protocols anygw
	list protocols batadv:%N1
	list protocols batadv:0

Thanks a lot @SAn

Glad to know that we hacked our way to the right answer

This is good to know. Thank you.
Most cases we would like to share the gateway within the network.
But when we create new network, we don’t want the gateways to be shared by default.
Is there a way to interconnect two community networks without sharing gateways?

Yes. The Babel config must be changed to do that.
I am not very sure how to do it (never studied the babeld config) but as a starting point I would say that you should have to change the rules so only the rules from each network are redistributed. Here is good info about it