Pirania Voucher Issue

Hola

I am unable to setup the voucher system in Pirania as shown here by @luandro


The problem is there is no “Access” option in the lime-app (thisnode.info)
How do I get that version of lime-app or activate this “Access” option?

As recommended by @nicopace, I updated the firmware of my librerouter to the latest: https://gitlab.com/librerouter/librerouteros/-/releases/
(Is there a command to check what version of firmware and other packages that are currently installed in the router?)

Hey @alemaree!

Lime-App with Pirania support has not yet been merged, so still not shipping with LibreRouter OS. You can create a build yourself from this branch.

Let us know if you need any help setting it up.

Cheers!

thanks for your reply @luandro

is there an another way to generate vouchers other than through lime-app?
am asking because pirania is there in my LRos and captive portal loads when enabled. just don’t know how to issue and manage vouchers. is there a command line option to do this?

Yes!

Sorry they are still not documented. But you can check the code here and see all the commands and their parameters.

If it’s too confusing let me know and I’ll take some time to document.

Oi Luandro, Boa!
I’m trying to add new vouchers using “voucher” commando on cli, but i don’t succes…
it’s like captive_portal.auth_voucher (mac,code) ??
I tryed:
captive_portal.add_voucher (“xx:…:xx:xx”,“cara”)
-ash: syntax error: unexpected word (expecting “)”)
-ash: syntax error: unexpected “)”
voucher add xx:…:xx:xx, cara
/usr/bin/lua: /usr/bin/voucher:148: attempt to call field ‘?’ (a nil value)
stack traceback:
/usr/bin/voucher:148: in main chunk
[C]: ?

…and many other combinations…

(xx:…:xx) is Mac address
Thanks!!