Static IP on the WAN port


I need help to set a static ip to the libre-router on the uplink/WAN side.
The uplink router/swtich does not have dhcp. I need to assign ip manually.
Is this possible?

Context: we have an event tomorrow where we want to stream the ip camera feeds through the libre router to the mesh and to the user phones. The ip camera feeds are sent to a switch and we can connect the LR to the switch but for that we have to assign a static ip as the cameras subnet do not have dhcp (the cameras are all in a manually configured subnet which cannot be disturbed). So the idea is to use the WAN port and connect to the switch - for this we need to assign a static ip on the LR.

Hi @alemaree, thanks for reaching out.
The relevant documentation for it is here:
Basically you will have to create a block of configuration in your /etc/config/lime-node config file, that looks like this:

config net port5					# Do not put any "." in the section name
	option linux_name 'eth1.5'			# Put here the actual name of the interface
	list protocols 'wan'				# Some of these protocols require the relative package "lime-proto-..."
	list protocols 'static'				# Set up a static IP (both IPv4 and IPv6 supported)
	option static_ipv4 ''
	option static_gateway_ipv4 ''
	option static_ipv6 '2a00:1508:0a00::1234/64'
	option static_gateway_ipv6 'fe80::1'

(Brought it from here: )

where eth1.5 is the wan interface, you will need to replace this with the one listed there (don’t have a LibreRouter at hand to check which interface is the one you need to use).

You can experiment and let us know.

Also maybe others can contribute, @SAn ?

hola nico,

thanks for your quick reply
however, with the event in full flow, we could not get the permission to access the ip cameras again.
so could not try out your suggestion.
we will experiment on this some time soon for sure though. we will update when we do that.


1 Like